motorola-logo
Register Your Product

Support For
Motorola COMFORT85 CONNECT, COMFORT85-2 CONNECT

Topic What are the minimum system requirements?

Related Products Motorola COMFORT85 CONNECT, COMFORT85-2 CONNECT

- Web Portal 
• Windows® 7 
• Mac OS® 10.7 
• Chrome™ 24 
• Internet Explorer® 9 
• Safari® 6 
• Java™ 7 
• Firefox® 18.0
• Adobe® Flash® Player 15.0 
- Android™ System 
• Version 5.0 or above 
- iPhone®/iPad® iOS 
• Version 8.0 or above 
- High Speed (Wi-Fi®) Internet 
• At least 0.6 Mbps upload bandwidth per camera (you can test your internet speed on this site: http://www.speedtest.net).

Related Articles

HAVE QUESTIONS? CONTACT OUR FRIENDLY SUPPORT.